re = /\b(?!(?:cookieToKeep1|cookieToKeep2)=)([^;=]+=[^;]*(?:; *|$))/m
str = 'someCookie=someValue; anotherCookie=yada61; cookieToKeep1=myValue; cookieToKeep2=myValue2; lastCookie=yada1'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result