#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(\w+)\b(?=.*\b\1\b)"
Local $sString = "foo foo" & @CRLF & _
"foo bar foo" & @CRLF & _
"foo bar baz foo" & @CRLF & _
"foo bar baz" & @CRLF & _
"foo" & @CRLF & _
"foo abcfoodef"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")