re = /\b(\w+)\b(?=.*\b\1\b)/m
str = 'foo foo
foo bar foo
foo bar baz foo
foo bar baz
foo
foo abcfoodef'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end