$re = '/\b(\w+)\b(?=.*\b\1\b)/m';
$str = 'foo foo
foo bar foo
foo bar baz foo
foo bar baz
foo
foo abcfoodef';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);