using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\bprotected\s|private\s|public\s|static\s\b)*)((?:.*)[;])";
string input = @"protected static autoEscape = true;
private documentAppendTitles;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}