$re = '`((?:\bprotected\s|private\s|public\s|static\s\b)*)((?:.*)[;])`m';
$str = 'protected static autoEscape = true;
private documentAppendTitles;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);