package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:\bprotected\s|private\s|public\s|static\s\b)*)((?:.*)[;])`)
var str = `protected static autoEscape = true;
private documentAppendTitles;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}