$re = '/^(?![ \t]*[sg]et[ \t]+\{.*\}).*\S[ \t]*\{/m';
$str = 'override var cornerRadius: CGFloat
{
get { return layer.cornerRadius }
set { layer.cornerRadius = newValue }
}
function Name(...) {
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);