re = /^(?![ \t]*[sg]et[ \t]+\{.*\}).*\S[ \t]*\{/m
str = 'override var cornerRadius: CGFloat
{
get { return layer.cornerRadius }
set { layer.cornerRadius = newValue }
}
function Name(...) {
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end