import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\h*[sg]et\\h+\\{.*\\}).*\\S\\h*\\{";
final String string = "override var cornerRadius: CGFloat\n"
+ "{\n"
+ " get { return layer.cornerRadius }\n"
+ " set { layer.cornerRadius = newValue }\n"
+ "}\n\n"
+ "function Name(...) {\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}