const regex = /^(?!\h*[sg]et\h+\{.*\}).*\S\h*\{/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\h*[sg]et\\h+\\{.*\\}).*\\S\\h*\\{', 'gm')
const str = `override var cornerRadius: CGFloat
{
get { return layer.cornerRadius }
set { layer.cornerRadius = newValue }
}
function Name(...) {
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}