package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)\.(.*?)\s*(\d\.\d{2})$`)
var str = `612. Grt. Am. Mgt. & Inv. 7.33
77. Wickes 4.61
265. Wang Labs 8.75
9. CrossLand Savings 6.32
228. JPS Textile Group 2.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}