const regex = /^(\d+)\.(.*?)\s*(\d\.\d{2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+)\\.(.*?)\\s*(\\d\\.\\d{2})$', 'gm')
const str = `612. Grt. Am. Mgt. & Inv. 7.33
77. Wickes 4.61
265. Wang Labs 8.75
9. CrossLand Savings 6.32
228. JPS Textile Group 2.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}