import re
regex = re.compile(r"^(\d+)\.(.*?)\s*(\d\.\d{2})$", flags=re.MULTILINE)
test_str = ("612. Grt. Am. Mgt. & Inv. 7.33\n"
"77. Wickes 4.61\n"
"265. Wang Labs 8.75\n"
"9. CrossLand Savings 6.32\n"
"228. JPS Textile Group 2.00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")