using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/(?:[^\\\/:*?""<>|\r\n]+\/)*[^\\\/:*?""<>|\r\n]+$";
string input = @"/ddd/dd%/ddfa/asdfasdf/asdfasdf=/asdfasdf6/Ű/ddd{/d/d";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}