re = /^\/(?:[^\\\/:*?"<>|\r\n]+\/)*[^\\\/:*?"<>|\r\n]+$/
str = '/ddd/dd%/ddfa/asdfasdf/asdfasdf=/asdfasdf6/Ű/ddd{/d/d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end