$re = '/^\/(?:[^\\\\\/:*?"<>|\r\n]+\/)*[^\\\\\/:*?"<>|\r\n]+$/';
$str = '/ddd/dd%/ddfa/asdfasdf/asdfasdf=/asdfasdf6/Ű/ddd{/d/d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);