using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\bjacket\b).*\badidas\b.*";
string input = @"1. ""I offer a jacket from adidas""
2. ""I offer clothing from adidas, a jacket""
3. ""By my adidas jacket""
4. ""adidas jacket""
5. ""jacket adidas""
6. ""I offer some shoes from adidas""
7. ""Selling some nice adidas shoes""
8. ""I have some shoes from adidas""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}