# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*\bjacket\b).*\badidas\b.*"
test_str = ("1. \"I offer a jacket from adidas\"\n"
"2. \"I offer clothing from adidas, a jacket\"\n"
"3. \"By my adidas jacket\"\n"
"4. \"adidas jacket\"\n"
"5. \"jacket adidas\"\n"
"6. \"I offer some shoes from adidas\"\n"
"7. \"Selling some nice adidas shoes\"\n"
"8. \"I have some shoes from adidas\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.