const regex = /^(?!.*\bjacket\b).*\badidas\b.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\bjacket\\b).*\\badidas\\b.*', 'gm')
const str = `1. "I offer a jacket from adidas"
2. "I offer clothing from adidas, a jacket"
3. "By my adidas jacket"
4. "adidas jacket"
5. "jacket adidas"
6. "I offer some shoes from adidas"
7. "Selling some nice adidas shoes"
8. "I have some shoes from adidas"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}