#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[a-zA-Z](?=[a-zA-Z ]{3})[a-zA-Z]* +[a-zA-Z]*"
Local $sString = "this is a test longtexthere a test" & @CRLF & _
"is a" & @CRLF & _
"abcd" & @CRLF & _
"a b" & @CRLF & _
" abc" & @CRLF & _
"abc d" & @CRLF & _
"a " & @CRLF & _
"" & @CRLF & _
"aa aa..., aaa a..., a aaa..., aaaa ..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")