re = /\b[a-zA-Z](?=[a-zA-Z ]{3})[a-zA-Z]* +[a-zA-Z]*/m
str = 'this is a test longtexthere a test
is a
abcd
a b
abc
abc d
a
aa aa..., aaa a..., a aaa..., aaaa ...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end