$re = '/\b[a-zA-Z](?=[a-zA-Z ]{3})[a-zA-Z]* +[a-zA-Z]*/m';
$str = 'this is a test longtexthere a test
is a
abcd
a b
abc
abc d
a
aa aa..., aaa a..., a aaa..., aaaa ...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);