#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!:\s)\b\w+(?<!\bas)\b\)*!"
Local $sString = "testing.(test)))!" & @CRLF & _
"" & @CRLF & _
"Details lists capture groups!" & @CRLF & _
"" & @CRLF & _
"hello as! hello" & @CRLF & _
"" & @CRLF & _
"Hello!" & @CRLF & _
"" & @CRLF & _
"testing!" & @CRLF & _
"" & @CRLF & _
"testing.test!" & @CRLF & _
"" & @CRLF & _
"Hello != World" & @CRLF & _
"" & @CRLF & _
"var noNetworkBanner: StatusBarNotificationBanner!" & @CRLF & _
"" & @CRLF & _
""var noNetworkBanner: StatusBarNotificationBanner!""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")