import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!:\\s)\\b\\w+(?<!\\bas)\\b\\)*!";
final String string = "testing.(test)))!\n\n"
+ "Details lists capture groups!\n\n"
+ "hello as! hello\n\n"
+ "Hello!\n\n"
+ "testing!\n\n"
+ "testing.test!\n\n"
+ "Hello != World\n\n"
+ "var noNetworkBanner: StatusBarNotificationBanner!\n\n"
+ "\"var noNetworkBanner: StatusBarNotificationBanner!\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}