$re = '/(?<!:\s)\b\w+(?<!\bas)\b\)*!/m';
$str = 'testing.(test)))!
Details lists capture groups!
hello as! hello
Hello!
testing!
testing.test!
Hello != World
var noNetworkBanner: StatusBarNotificationBanner!
"var noNetworkBanner: StatusBarNotificationBanner!"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);