$re = '/(?m)^(?:(?<!^)(?:(?!\1|\2|\3)([\'])|(?!\1|\2|\3)([-])|(?!\1|\2|\3)([ ]))(?!$)|[a-zA-Z]){1,50}$/';
$str = '5
foster
foster steve
foster-morrison
hello
*RKER(($(#$)#$#L$KLK#$*
dfkfsdkfskdfjksjfksfksjfskjfksjfskfksjfksfksfskfd
jkddkdkdkdkdkdkdkdkfdkd-ffddfdfdfdgggfgfgfgggggggg
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfgggggggd
dkfkerksf------aaa-----
test---me
foster-mo
f-morrison
griffith-joiner
test-
-dkd
d\'andre
d\'andre-jordan
jordan-d\'andre';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);