import Foundation
let pattern = #"(?m)^(?:(?<!^)(?:(?!\1|\2|\3)(['])|(?!\1|\2|\3)([-])|(?!\1|\2|\3)([ ]))(?!$)|[a-zA-Z]){1,50}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
5
foster
foster steve
foster-morrison
hello
*RKER(($(#$)#$#L$KLK#$*
dfkfsdkfskdfjksjfksfksjfskjfksjfskfksjfksfksfskfd
jkddkdkdkdkdkdkdkdkfdkd-ffddfdfdfdgggfgfgfgggggggg
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfgggggggd
dkfkerksf------aaa-----
test---me
foster-mo
f-morrison
griffith-joiner
test-
-dkd
d'andre
d'andre-jordan
jordan-d'andre
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)