# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^(?:(?<!^)(?:(?!\1|\2|\3)(['])|(?!\1|\2|\3)([-])|(?!\1|\2|\3)([ ]))(?!$)|[a-zA-Z]){1,50}$"
test_str = ("5\n"
"foster\n"
"foster steve\n"
"foster-morrison\n"
"hello\n"
"*RKER(($(#$)#$#L$KLK#$*\n"
"dfkfsdkfskdfjksjfksfksjfskjfksjfskfksjfksfksfskfd\n"
"jkddkdkdkdkdkdkdkdkfdkd-ffddfdfdfdgggfgfgfgggggggg\n"
"jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfgggggggd\n"
"dkfkerksf------aaa-----\n"
"test---me\n"
"foster-mo\n"
"f-morrison\n"
"griffith-joiner\n"
"test-\n"
"-dkd\n"
"d'andre\n"
"d'andre-jordan\n"
"jordan-d'andre")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.