const regex = /(.*),(.*)N(.*)E(.*)(A.*) (A.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*),(.*)N(.*)E(.*)(A.*) (A.*)', 'gm')
const str = `ALARM,A:341N572964E012045499 A12002172140U AlarmButton R:5 B:4 G:F`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}