re = /(.*),(.*)N(.*)E(.*)(A.*) (A.*)/m
str = 'ALARM,A:341N572964E012045499 A12002172140U AlarmButton R:5 B:4 G:F'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end