// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*),(.*)N(.*)E(.*)(A.*) (A.*)").unwrap();
let string = "ALARM,A:341N572964E012045499 A12002172140U AlarmButton R:5 B:4 G:F";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}