$re = '/\[(School_Teacher_Name)]/m';
$str = '[School_Teacher_Name] is our new member, So please congratulate [School_Teacher_Name] .';
$subst = "Yash Mathur";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;