import Foundation
let pattern = #"\[(School_Teacher_Name)]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[School_Teacher_Name] is our new member, So please congratulate [School_Teacher_Name] ."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Yash Mathur"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)