// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[(School_Teacher_Name)]").unwrap();
let string = "[School_Teacher_Name] is our new member, So please congratulate [School_Teacher_Name] .";
let substitution = "Yash Mathur";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}