# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<(\w+)>)\s*(.*?)\s*(<\\/\2>)/\1\3\4/gm;t' <<< "<h1>
<page num=\"1\" />
<b><i>Britons United By Lost Hope, If Nothing Else</i></b>
</h1>
<h2>
<b><i>Many Feel Brexit Has Democracy on Trial</i></b>
</h2>
<h3>
<page num=\"18\" />
<b><i>Britons Are Feeling United by a Lost Hope in Democracy, if Nothing Else</i></b>
</h3>
<fig>
<img src=\"images/img_103-5.jpg\" width=\"442\" height=\"261\" alt=\"\" />
<fc>Ann Dwyer, Thomas Dunn</fc>
<cr>AMANDA REYNOLDS OF PLUME PHOTOGRAPHY</cr>
</fig>
</break>"