$re = '/^[a-z]([a-z]+\d*|\d{2,})$/im';
$str = 'Paul46
4frank
mike
jus6tin
p87
k9
AL10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);