import re
regex = re.compile(r"^[a-z]([a-z]+\d*|\d{2,})$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("Paul46\n"
"4frank\n"
"mike\n"
"jus6tin\n"
"p87\n"
"k9\n"
"AL10")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")