import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A|C][1-9|A-HJ-PR-UW-Y][0-9][1-9|A-C][1-9|A-HJ-PR-UW-Y][0-9|A-HJ-PR-UW-Y]{3}[A-HJ-PR-UW-Y]{2}";
final String string = "A131K062CE04\n"
+ "A131K062CA04\n"
+ "A131K062CA\n"
+ "A131K062CE\n"
+ "A131K062CE\n"
+ "AZ31K062CE04\n"
+ "A136P099BH\n"
+ "A136Q09YBK \n"
+ "A136S02QCE\n"
+ "A136R09QAY\n"
+ "A136F04QBV\n"
+ "A136F08QAB\n"
+ "C136Q03UAU\n"
+ "A136D05BCG\n"
+ "A136B041AQ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}