# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[A|C][1-9|A-HJ-PR-UW-Y][0-9][1-9|A-C][1-9|A-HJ-PR-UW-Y][0-9|A-HJ-PR-UW-Y]{3}[A-HJ-PR-UW-Y]{2}"
test_str = ("A131K062CE04\n"
"A131K062CA04\n"
"A131K062CA\n"
"A131K062CE\n"
"A131K062CE\n"
"AZ31K062CE04\n"
"A136P099BH\n"
"A136Q09YBK \n"
"A136S02QCE\n"
"A136R09QAY\n"
"A136F04QBV\n"
"A136F08QAB\n"
"C136Q03UAU\n"
"A136D05BCG\n"
"A136B041AQ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.