// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A|C][1-9|A-HJ-PR-UW-Y][0-9][1-9|A-C][1-9|A-HJ-PR-UW-Y][0-9|A-HJ-PR-UW-Y]{3}[A-HJ-PR-UW-Y]{2}").unwrap();
let string = "A131K062CE04
A131K062CA04
A131K062CA
A131K062CE
A131K062CE
AZ31K062CE04
A136P099BH
A136Q09YBK
A136S02QCE
A136R09QAY
A136F04QBV
A136F08QAB
C136Q03UAU
A136D05BCG
A136B041AQ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}