using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\/\w+)+(?:\.\w+)?(?:;(?:\/\w+)+(?:\.\w+)?)$";
string input = @"/root/product/db.main;/root/product/db.part
/root/product/db.main
/root/product/db.main;
/root/product/db.main;/root/product/db.part;/root/product/db.main;/root/product/db.part";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}