$re = '/^(?:\/\w+)+(?:\.\w+)?(?:;(?:\/\w+)+(?:\.\w+)?)$/m';
$str = '/root/product/db.main;/root/product/db.part
/root/product/db.main
/root/product/db.main;
/root/product/db.main;/root/product/db.part;/root/product/db.main;/root/product/db.part';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);