package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\/\w+)+(?:\.\w+)?(?:;(?:\/\w+)+(?:\.\w+)?)$`)
var str = `/root/product/db.main;/root/product/db.part
/root/product/db.main
/root/product/db.main;
/root/product/db.main;/root/product/db.part;/root/product/db.main;/root/product/db.part`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}