import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{[^)]+";
final String string = "var block = new MatchesBlock('page_competition_1_block_competition_matches_summary_5', 'block_competition_matches_summary', {\"page\":0,\"bookmaker_urls\":{\"13\":[{\"link\":\"http:\\/\\/www.bet365.com\\/home\\/?affiliate=365_178981\",\"name\":\"Bet 365\"}]},\"block_service_id\":\"competition_summary_block_competitionmatchessummary\",\"round_id\":42011,\"outgroup\":false,\"view\":2,\"competition_id\":13});";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}