// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"{[^)]+").unwrap();
let string = "var block = new MatchesBlock('page_competition_1_block_competition_matches_summary_5', 'block_competition_matches_summary', {\"page\":0,\"bookmaker_urls\":{\"13\":[{\"link\":\"http:\\/\\/www.bet365.com\\/home\\/?affiliate=365_178981\",\"name\":\"Bet 365\"}]},\"block_service_id\":\"competition_summary_block_competitionmatchessummary\",\"round_id\":42011,\"outgroup\":false,\"view\":2,\"competition_id\":13});";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}