use strict;
my $str = 'var block = new MatchesBlock(\'page_competition_1_block_competition_matches_summary_5\', \'block_competition_matches_summary\', {"page":0,"bookmaker_urls":{"13":[{"link":"http:\\/\\/www.bet365.com\\/home\\/?affiliate=365_178981","name":"Bet 365"}]},"block_service_id":"competition_summary_block_competitionmatchessummary","round_id":42011,"outgroup":false,"view":2,"competition_id":13});';
my $regex = qr/{[^)]+/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}