package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[a-z]{1,2}+(?:[a-z]{2,})?\b`)
var str = `an of and then some an ee halved or or whenever`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}