const regex = /\b[a-z]{1,2}+(?:[a-z]{2,})?\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[a-z]{1,2}+(?:[a-z]{2,})?\\b', 'g')
const str = `an of and then some an ee halved or or whenever`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}