$re = '/\b[a-z]{1,2}+(?:[a-z]{2,})?\b/';
$str = 'an of and then some an ee halved or or whenever';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);